Damn You Ping Times!!!!! >:(

Discussion in 'Technical Support' started by xiZombYix, Jul 11, 2014.

  1. #1
    OK to start this off, I would like to say that before (at least before the recent update) I was getting near flawless connection to the Firefall servers while I played this game. Now (after the recent update) I am occasionally getting ping times ranging from 300-1200 at times. How my game doesn't crash IDK but that's beside the point. What I want to get across to everyone is that I am getting crazy abnormal ping times that I honestly don't think I should be getting at all. If anyone knows of somethings I can possibly do to solve this problem, or at least lower my ping times substantially, it would be awesome if you could post your tips or ideas here because I really do not want to uninstall this game as I love it so much. Thanks in advance.

    P.S: I did send a support ticket to the devs about this and currently I am in a conversation with them about this issue so please try not to tell me to go and send a ticket. Also, I have tried (still am trying) the addon called "Boing" to switch to different shards and what not but the low ping times i get by doing so are very short lived.
  2. Kristakis Engineer Specialist

    #2
    Have a look in your console (ALT+F1) and find the IP address of the server you're on. From a command prompt, run tracert <that ip> and see what you get. For example, I get this to the mainwebsite (I'm at work so don't have an in-game server IP)

    C:\Users\chris>tracert firefallthegame.com

    Tracing route to firefallthegame.com [216.146.46.10]
    over a maximum of 30 hops:

    1 <1 ms <1 ms <1 ms 192.168.1.1
    2 21 ms 21 ms 21 ms gw101.cha24.brisbane.telstra.net [203.46.203.142]
    3 22 ms 23 ms 23 ms tengige0-8-0-2.cha-core4.brisbane.telstra.net [203.50.51.1]
    4 41 ms 38 ms 39 ms bundle-ether11.ken-core4.sydney.telstra.net [203.50.11.72]
    5 41 ms 38 ms 39 ms bundle-ether19.ken-core10.sydney.telstra.net [203.50.11.129]
    6 40 ms 39 ms 39 ms Bundle-ether18.pad-gw2.sydney.telstra.net [203.50.13.82]
    7 40 ms 38 ms 39 ms bundle-ether1.sydp-core01.sydney.reach.com [203.50.13.46]
    8 175 ms 174 ms 175 ms i-0-3-0-3.paix-core01.bx.telstraglobal.net [202.84.140.37]
    9 174 ms 173 ms 173 ms i-0-5-0-5.paix02.bi.telstraglobal.net [202.40.149.126]
    10 174 ms 173 ms 174 ms te0-0-0-3.ccr21.sjc04.atlas.cogentco.com [154.54.11.157]
    11 174 ms 175 ms 174 ms be2015.ccr21.sfo01.atlas.cogentco.com [154.54.7.173]
    12 212 ms 213 ms 212 ms be2132.ccr21.mci01.atlas.cogentco.com [154.54.30.54]
    13 225 ms 224 ms 225 ms be2156.ccr41.ord01.atlas.cogentco.com [154.54.6.86]
    14 247 ms 247 ms 247 ms be2114.ccr21.jfk02.atlas.cogentco.com [66.28.4.201]
    15 248 ms 248 ms 247 ms te4-1.ccr01.jfk08.atlas.cogentco.com [154.54.27.214]
    16 247 ms 248 ms 247 ms 38.104.190.54
    17 244 ms 243 ms 243 ms firefallthegame.com [216.146.46.10]

    Hops 7-10 are the trans-pacific ocean undersea cable so I get a jump in latency from that (I'm in Australia). Your route will be different but you can find where the delays increase. If you like, grab a copy of PingPlotter off the net, it's pretty much the same thing but much prettier.

    Also, try /net_graph from in-game chat and see what you get from that.

    Another thing to check/try is changing your DNS to 8.8.8.8 and 8.8.4.4 instead of using your local router. This workaround will cause patching to slow down so only use it as a test.
  3. #3
    Hmm Ok. Ill try what you mentioned and hopefully it works better.
  4. #4
    Ok So i ran a tracert like you did and this is what came up: Tracing route to vpc-ping-01.vpc01.us-east-1.r5external.com [107.23.190.27]
    over a maximum of 30 hops:

    1 <1 ms 2 ms <1 ms 10.0.0.1
    2 8 ms 10 ms 7 ms 73.205.18.1
    3 11 ms 9 ms 7 ms te-0-2-0-5-sur01.plymouth.mn.minn.comcast.net [68.85.166.177]
    4 14 ms 10 ms 11 ms te-0-7-0-4-ar01.roseville.mn.minn.comcast.net [69.139.219.70]
    5 106 ms 42 ms 36 ms he-1-13-0-0-cr01.350ecermak.il.ibone.comcast.net [68.86.94.81]
    6 55 ms 56 ms 55 ms he-4-7-0-0-cr01.newyork.ny.ibone.comcast.net [68.86.88.157]
    7 * * * Request timed out.
    8 53 ms 55 ms 54 ms 50.242.148.122
    9 66 ms 65 ms 61 ms 54.240.229.78
    10 70 ms 65 ms 72 ms 54.240.228.188
    11 62 ms 60 ms 77 ms 54.240.229.219
    12 * * * Request timed out.
    13 65 ms 62 ms 60 ms 72.21.220.118
    14 63 ms 66 ms 65 ms 72.21.220.165
    15 70 ms 94 ms 464 ms 72.21.222.147
    16 * * * Request timed out.
    17 * * * Request timed out.
    18 * * * Request timed out.
    19 78 ms 81 ms 80 ms ec2-107-23-190-27.compute-1.amazonaws.com [107.23.190.27]

    Trace complete.
  5. Kristakis Engineer Specialist

    #5
    So you are getting 80ms to the server, that's pretty good. Try /showping in-game to see your ping while playing. You can use /showfps to show your framerate too. Use the command again to hide.

    So, what problems are you having in-game that makes you think it's ping?
  6. #6
    Yeah that's what bothers me. When I go to type "showping" it fluctuates ALOT between 80-1300+ but it mainly stays at higher pings making it near impossible to move.
  7. Kristakis Engineer Specialist

    #7
    try the net_graph command and see if there's a pattern. Do you have these spikes with other games?
  8. #8
    You are not alone in this man - a friend and I have joined the game (in the last few days) and the ping was all over the joint and rubber-banding/teleporting was bad. I usually get 200ms (give or take) but it was fluctuating from 197ms - 347ms and everywhere in between. I remember this use to be an issue with the game early on, but then it was fixed - perhaps there is an increase in players and it's causing issues. I really hope they fix it - in fact, I would really love (never happen) a server close/in Australia. For a more twitch based mmo, it will been really handy come higher PVE content and especially for PVP.
  9. #9
    Sorry I forgot to reply to you about this sooner, but what exactly am I supposed to look at with the command? When I typed it in it fluctuated all over the place so idk what that means.
  10. Kristakis Engineer Specialist

    #10
  11. #11
    Well yesterday I got a constant 190ms, but it was during the day here in Australia so not exactly peak time - I just went into the game at 1.30am and the ping is unplayable, back up to 270+ms minimum fluctuating to 370+ms.

    Combine this with the weird stuttering I'm getting with my frames and I can't play this game :( Founder/commander + DD (not to mention the red beans I've spent) and I can't play the game after all this time - much sad.
  12. #12
    I am having this issue as well, I'll raise a ticket and see if there's any way to fix it but I don't expect anything without an oceanic server.
  13. #13
    ok, right now I sit at 350 and jump all the way up to 600+ms - this is crazy!
  14. #14
    I raised a ticket and support put it down to launch issues - but that's not right. I've never had this drama before, not a such a regular basis. I know for a fact this occurred during beta but they fixed it - we really need a fix for this, because between this and my fps dips - I'm going crazy.