Need Info FireFall cannot run on GTX970

Discussion in 'Technical Support' started by IamRenXD, Apr 19, 2017.

  1. #1
    Guys, I need some help. Is anyone here using GTX970 playing firefall? I am using Steam app to play firefall and I had downloaded firefall and launch it with my Acer Predator. The Task Manager is showing the firefall is launching, but there are nothing jump out on my screen. Can somebody help me solve this problem?
  2. #2
    I think you have the same bug that many of us have, it's a wierd issue with update server contact.
    Open the FF folder and launch the FF launcher without steam, and it should say update available. If you click update, it will tell you it can't find the server, and the button will change to Play. The game launches as you describe, it shows in Task Manager but not on screen in any way.
    I haven't found any fix for this and can't play at all.
    I used the GTX 970 for about a year and a half with no problems. Now I have a GTX 1080, but cant run the game, grrrrr.
  3. #3

    I got exactly the same problem, it's started about 4 days ago... And i didn't change any hardware, everything stay the same. But also i got update of mine Win 10.
  4. Firemoth Commander

    #5
    could also be a driver issue, nvidia drivers broke firefall about a month or a few releases ago. try a driver older than 376.xx
  5. #6
    I had tried your guide launch FF without steam app, but it was still the same problem after i clicked play there was nothings pop out :'(
  6. #7
    I can launch FF now just using old AMD GPU driver... In my case it's Radeon Software Version 16.12.2. Maybe you also can search for last year's driver?