Released [Tool] <Addon Manager> Melder

Discussion in 'Addons' started by RadthorDax, Aug 24, 2012.

  1. RadthorDax Commander

    I dont get why people keep calling Melder an addon. :confused:
    • Like x 3
  2. Maybe you need to expand your imagination ^^
  3. RadthorDax Commander

    Firefall's Lua compiler has IO disabled for security reasons, so you cannot do anything to the filesystem from within an addon. Otherwise Melder would have been an addon itself from the very start. ;)
    • Like x 1
  4. StormWing0 Beta Vanguard

    The main issue I ran into with the 0.99 melder is it never showed updates and it couldn't find the ini files in the zip files. Aside from that it is good. :)
  5. RadthorDax Commander

    Can you show me some screenshots? I've not seen any reports of Melder not detecting ini files in zip files before, and it's been doing that for about 7 months.
  6. StormWing0 Beta Vanguard

    hmm that is strange, might just be me being unlucky or something but here's some screenshots.
    InstallCheckBoxClicked.png OneKnownLocation.png UdateButtonClicked.png WhereItIsWhenDownLoaded.png
  7. RadthorDax Commander

  8. StormWing0 Beta Vanguard

    I posted one showing the zip in the melder library directory, seems to move the ini file around for some reason. The other is showing where it was in the first place in the original download. Basically two copies of the same zip but two different places in the file system. :) Thought the file paths up top would give that away. >_>
  9. RadthorDax Commander

    Ah right. Melder moves the ini file into the root for easy access so it doesnt have to search for it after the first time. Wasn't completely sure if another ini file would conflict. Can you paste the contents of one of the ini files that are in your current addon directory?
  10. How do I get this to work with Windows 8 64-bit?
    The checkboxes doesn't pop up..
    When I try to update Melder, it gives me the "Stopped working" error and/or restarts the program and asks to update again.
    I have tried running as admin, but it doesn't work.
  11. RadthorDax Commander

    Looks like you are experiencing 2 issues. (think of it like winning the lottery? :confused:)

    The checkboxes arent displaying because your window's style font DPI is too large for the space allotted them. For now, select the addon entry and press space to install and uninstall. There is a fix for this problem in the upcoming version.

    The second issue is you seem to be stuck in an update loop. I still haven't found a definitive reason why this happens, and I'm unable to replicate it. I've fixed a potential cause, but I wont be able to get feedback till the next version is more stable. For now, if you open the settings menu and disable automatic update checking, you'll stop seeing the popups for this each time you start.
    • Like x 1
  12. AHHHHH! It is in this thread further back a few/several pages.


    But I will explain again
    Highlight the addon you want installed press SpaceBar. Profit.

    I got ninja'd :(
  13. Cant the update loop be fixed by removing the %LOCLAAPPDATA%/Melder folder and rerunning the application?


    Hmm maybe not, I am still waking up I might need to wait a little longer before I start trying to read posts.
  14. I apologize for my laziness, since there's 19 pages :S
    I looked at some of the previous pages and found some 'fixes', but none have seemed to work.. I also forgot to tell you, that I don't even see any addons in Melder..
    I have tried moving them into all kinds of folders including:
    C:\Program Files (x86)\Red 5 Studios\Firefall\system\gui\components\MainUI
    C:\Program Files (x86)\Red 5 Studios\Firefall\system\gui\components\MainUI\Addons
    C:\Program Files (x86)\Red 5 Studios\Firefall\system\melder_addons
    Melder bug.png
  15. RadthorDax Commander

    Ah! Thats because you shouldn't extract the zip files into the addon library. Melder reads zips just as they are when downloaded form the forum.

    From the instructions in the main post:
  16. Bpsmooth Mentor

    Can you give the route to locating and opening melder after it is downloaded? I can't seem to find it. I have searched for it by typing and by looking through folders. Thanks!
  17. RadthorDax Commander

    Its wherever you have told your web browser is your default download location. I don't have any control over that :confused:

    If you want to make sure you know where it is, rightclick the link and click "Save Link As". You'll be able to select the location it downloads to.
  18. anyone else not been able to get melder working?

    Hey,

    I used melder once before but it never really worked for me. Thought id try once more.

    I have no check boxes like you do but I can only simulate install?

    I uploaded a picture here for you. Would really appreciate your help:
    http://i.imgur.com/P4o2bxP.jpg
  19. From the page previous to this one.
    You should be able to use Space bar when highlighted to install an addon. Possibly Enter/Return but I do not have Win 8 or this issue so I can not say for certain on either.
    • Like x 1
  20. oho thanks sounds like this was my issue too. Im trying deads suggestion (space for every addon).

    Woohoo this worked! (windows 7)